Topic: dixon zamora

Saludos espero  pueda orientarme en dar solucion al siguinte error : The xml response that was returned from the server is invalid recived <br>? xml version="1.0" encoding="utf-8"?><xjx></xjx>

mi codigo es el siguiente
<?php    
    require('../xajax/xajax.inc.php');
    $xajax=new xajax();       
    $xajax->registerFunction("buscar");
    $xajax->registerFunction("guardar");
    $xajax->registerFunction("asignar");
    $xajax->registerFunction("nuevo");
    require("manejoSql.php");
   
    function buscar($cedula){
        $obj=new xajaxResponse();
        $cone=new manejoSql();                                   
        $cone->conexionSql();
        $cone->seleccionarBd();
        $cadena="select * from usuario where clave='$cedula'";
        $resul=$cone->consultaTABLA($cadena);
        $nombre=$resul['nombre'];
        $obj->addAlert($nombre);
        return $obj;
    }
?>

Re: dixon zamora

Hola,

Lo único que veo es la Red de etiquetas antes de la etiqueta xml y los desaparecidos <al principio de la etiqueta ... La etiqueta de salto es el culpable más probable.

Se debe tener este aspecto: <? Xml version = encoding "1.0" = "UTF-8">

A su vez tal vez en el degugger xajax. Asegúrese de que no hay caracteres iniciales o finales antes o después de las etiquetas php.

¿Has pensado en utilizar la última versión xajax? v0.5 v0.6 es estable y se encuentra todavía en fase beta.

Ed

If you ever stop learning you may as well dig a hole, crawl in and pull the top over yourself.