1

Topic: function addAppend behaivors different for FireFox and IE

Hi, I am having the issues with appending some data into div element in IE ( it works fine in FireFox ). Will be better then I post some code too:
Try to descibe what I am trying to do. There is a list of items ( let's say it is online-shop), you click on item, item get selected and put into shopping cart.
[code]//adding the selected item from the list of items to the shopping cart
function add2shoppingCart($itemId) {
  $objResponse = new xajaxResponse();
  ...
  //get selected item title
  $cartItem = '<div>'.$items[$itemId][0].'

Re: function addAppend behaivors different for FireFox and IE

It could be that IE doesn't like some of the HTML that you are attempting to append / assign.  Try changing the addAppend to an addAssign and see if the same items that fail as an append, fail as an assign.  If this is the case, check your data for invalid characters like < > and &... if they exist, convert them to HTML equiv first (< > & )

Hope that helps.

// Joe

xajax Developer
Connect to me on LinkedIn:
http://www.linkedin.com/in/calledtoconstruct

3

Re: function addAppend behaivors different for FireFox and IE

To CtC: looks like IE doesn't like any tags at all while trying to append some data :-(. In my case I can redraw the shopping cart each time the new item was selected. But it still does not solve the original problem with appending nodes in IE. Anyway, thanks for responding.
Cheers,
Milan

Re: function addAppend behaivors different for FireFox and IE

Troubleshooting This topic is very quite.................