Topic: xajaxPluginManager.inc.php in xajax 0.5 beta 4b

Why there is a following mistake?

I use xajax_0.5_beta_4b_Standard\tests\suite

Notice: Only variables should be assigned by reference in Z:\home\0.ru\8\xajax_core\xajaxPluginManager.inc.php on line 268

Notice: Only variables should be assigned by reference in Z:\home\0.ru\8\xajax_core\xajaxPluginManager.inc.php on line 268

Notice: Only variables should be assigned by reference in Z:\home\0.ru\8\xajax_core\xajaxPluginManager.inc.php on line 268
Output has already been sent to the browser at Z:\home\0.ru\8\xajax_core\xajaxPluginManager.inc.php:268. Please make sure the command $xajax->processRequest() is placed before this.

Re: xajaxPluginManager.inc.php in xajax 0.5 beta 4b

I have the same problem trying to integrate xajax with CodeIgniter.
I'm using php4.4.3-dev and I get the problem with both standard and compiled xajax_0.5 beta_4b

I think it's related to :
http://community.xajaxproject.org/viewtopic.php?id=5680

Re: xajaxPluginManager.inc.php in xajax 0.5 beta 4b

Hallo community,

i encountered the same problem with PHP Version 4.4.1 on IIS webserver. Is there a workaround or a update yet around?

Notices:
Notice: Only variables should be assigned by reference in ... xajax_core\xajaxPluginManager.inc.php on line 268

xajax version: xajax 0.5 beta 4

thanks
xajusername

Re: xajaxPluginManager.inc.php in xajax 0.5 beta 4b

same problem, xajax version: xajax 0.5 beta 4
php 4.4.4

Re: xajaxPluginManager.inc.php in xajax 0.5 beta 4b

Just remove the & symbol on the line 268.

Couses the error:

$mResult =& $objPlugin->register($aArgs);

Fix the error:

$mResult = $objPlugin->register($aArgs);

Re: xajaxPluginManager.inc.php in xajax 0.5 beta 4b

Remove

error_reporting(E_ALL);

line if you use.

Re: xajaxPluginManager.inc.php in xajax 0.5 beta 4b

Hey, I know that this post is from 2007... I'm new on this, I'm working on an old project from a friend with the same problem.

If I remove the symbol & like DjFaDDe said I fix the error, but appears some other errors... haha

error_reporting(E_ALL) is not a solution for me.

I'm not sure about what version of the xajax I'm using... but i think it's not the final 0.5 version.

The error don't appears on the localhost, only on the server.

So.. what can i do to fix this error?


Sorry for my English, I'm from Barcelona, Spain.

Re: xajaxPluginManager.inc.php in xajax 0.5 beta 4b

Hello,

Welcome.

This has come up often and the removal of the & has always fixed it.

What other errors are you seeing? If it the same thing referring to different xajax files you canjust edit them and remove the ampersand from the indicated lines.

If you open the file xajax/xajax_core/xajax.inc.php and search for "version" you can find the version you are using.

Sounds like the server may be running a later version of PHP which enforces this rule.

Ed

If you ever stop learning you may as well dig a hole, crawl in and pull the top over yourself.