Re: [alpha] Comet streaming

I did try again with a clean install from the zip in this thread... and I had the same issue, the streaming did not work. Only the examples from the standard distribution worked. Could it be an issue with the server configuration?

Re: [alpha] Comet streaming

Did you take the xajax from the comet zip file or did you download it from sourceforge? The comet.zip contains some changes that were made after the beta4 release. I've taken the latest SVN rev. Your site works fine in IE - so I guess you took another vers smile

Re: [alpha] Comet streaming

Hi,

Thanks for the suggestions. Here's where I am at. IE7 works fine except that it eats up memory because of the iframe issue. FoxFire (2.0.0.11) does not see to work. It loads the page and gets the first stream and then does not update, it just hangs on the hour glass.

Your suggest would be apreshiated.

Thanks,

jreda

29 (edited by tyclipso.net 2008-01-29 10:23:35 AM)

Re: [alpha] Comet streaming

Hi Guys.

I use comet, too. It's pretty nice. But i think there's a bug. If I start the stream and another xajax-request on the same time in your example the requests are executed. If I start another request while a stream runs the other request executes after finishing the stream. Is this Problem a known one?

Please help me.

PS: Can you Post a Screenshot that shows the phpinfo()? Is it possible that this is a Server-Problem?

Re: [alpha] Comet streaming

Hi,

you are probably using sessions and the streaming process is locking your session file - so all other processes using the same session are waiting for the streaming process to unlock the session. Search for session_write_close() in our forums and you'll find alot of answers.
Let me know if that works smile

Re: [alpha] Comet streaming

Hi there.

I have problems using comet in IE 7 (IE 6 not tested). When the comet-script starts or flushes the response back the error "Ung

Re: [alpha] Comet streaming

Hmm... that's the point where the Iframe is created. Is ActiveX disabled in your browser?

Re: [alpha] Comet streaming

That's right. I know about the IFrame in IE. ActiveX is enabled - no restrictions. The Standard-configuration of IE is set.
If I comment the line 192 the streaming works well. It must be a bug.

Re: [alpha] Comet streaming

That's odd... It works as expected in my IE, but I'll put it on my todo list. I'm wondering if anyone else is having this issue as well.

Re: [alpha] Comet streaming

The Streaming works fine now. I've set a custom-security-level in IE and allowed some not recommended scripts. Then the IE works well. After that I set the security-level to standard (medium-high), but the streaming works furthermore...? But only if I comment line 192. in xajax.inc.js

Another Problem occurs if I test it in Safari 3.5 / 3.5 Nightbuild. In this Browser there comes a warning, that the comet-streaming is disabled in Safari. (you'll see it on the screenshot) On your website you write, that comet is available in safari 3???

Screenshot

Re: [alpha] Comet streaming

Yep, I know that issue. Safari supports streaming as well as Firefox does, but my browser detections sucks at this point, sorry. I'm going to fix it soon, but haven't got the time atm.

Re: [alpha] Comet streaming

I get this error:

<b>
Fatal error: Failed to locate registration method for the following: Array ( [0] => XAJAX_COMET [1] => testComet ) in /home/.gunther/newfairlady/newfairlady.spiral-labs.com/xajax/xajax_core/xajaxPluginManager.inc.php on line 283
</b>

Re: [alpha] Comet streaming

Yes, please read this thread http://community.xajaxproject.org/viewt … p?id=6347. There's a new vers out.