Topic: Setting up XAJAX 0.6b1 with CodeIgniter...

I've been using xajax for pretty much every project I do... heres how to get it working with codeigniter.

http://codeigniter.com/forums/viewthread/182897/

Hope this helps someone.

Re: Setting up XAJAX 0.6b1 with CodeIgniter...

Brendan,

Thanks much for this.

I have been considering frameworks and CI in particular. Without XAJAX it looks like you can only update a single DOM element at a time. Now maybe I can get into it and learn it...

Ed

If you ever stop learning you may as well dig a hole, crawl in and pull the top over yourself.

Re: Setting up XAJAX 0.6b1 with CodeIgniter...

Hey Brendan,

I have jumped into CI and think I will use it for everything henceforth.

I am posting this in case someone else runs into the problem I have had using MY_Controller to extend CI_Controller.

I used the method of integrating xajax given here http://codeigniter.com/wiki/Xajax_perfect_setup/

Everything was fine until I tried to extend CI_Controller with MY_Controller. None of my models,etc would get loaded in the derived controllers.

Finally figured it out. I had the call to processRequest() in MY_Controller's constructor so nothing after that was ever called.

Put the call in the derived controller, after your calls to load and everything works great.

Hope this helps someone out.

Ed

If you ever stop learning you may as well dig a hole, crawl in and pull the top over yourself.

Re: Setting up XAJAX 0.6b1 with CodeIgniter...

http://codeigniter.com/forums/viewthread/93033/
CodeIgniter_2.1.0 with XAJAX 0.6b i removed the ajax_init and its working