Topic: xajax's functions dont work on label <input>

Hi!! sorry because i dont write very well english..
here  attached the form and HELP ME please..

<FORM  name="form1" id="form1" action="#" method="post">
                <table border="0"> 
                 <tr><td colspan="3"><div id='DivGlobal'></div></td></tr>
                <tr>
                      <td align="right" width="220px" class="Campos">Nick: </td>
                    <td width="200px">    
                        <INPUT tabindex="1" id="nick" TYPE="text" NAME="nick" SIZE=28 MAXLENGTH=20 onkeyup="<?php //xajax_FormManage(xajax.getFormValues('form1'),'nick')?>" />
                    </td>
                    <td align="left" width="300px"><div id="divnick"></div></td>
                  </tr>    
                    <BR>
                <tr>
                    <td align="right" width="220" class="Campos"> Password:</td>
                    <td width="200">   
                        <INPUT tabindex="2" id="pass" TYPE="password" NAME="pass" SIZE=28 MAXLENGTH=20 onkeyup="<?php //xajax_FormManage(xajax.getFormValues('form1'),'pass') ->printScript();?>"> 
                    </td>
                    <td align="left" width="300"><div id="divpass"></div></td>
                </tr>
                      <BR>
                <tr>
                    <td align="right" width="220" class="Campos">Repetir Password:</td>
                    <td width="200">
                        <INPUT tabindex="3" id="pass1" TYPE="password" NAME="pass1" SIZE=28 MAXLENGTH=20 onkeyup="<?php //xajax_FormManage(xajax.getFormValues('form1'),'pass1') -> printScript();?>">
                    </td>
                    <td align="left" width="300"><div id='divpass1'></div></td>
                </tr>
                    <BR>
                <tr>
                    <td align="right" width="220" class="Campos">Nombre:</td>
                    <td width="200">  
                        <INPUT tabindex="4" id="nombre" TYPE="text" NAME="nombre" SIZE=28 MAXLENGTH=255  onkeyup=" <?php //xajax_FormManage(xajax.getFormValues('form1'),'nombre') ->printScript();?>" >
                    </td>
                    <td align="left" width="300"><div id='divnombre'></div></td>
                </tr>
                      <BR>
                <tr>    
                      <td align="right" width="220" class="Campos">Email:</td>
                    <td width="200">   
                        <INPUT tabindex="5" id="email" TYPE="text" NAME="email" SIZE=28 MAXLENGTH=100 onkeyup="<?php //xajax_FormManage(xajax.getFormValues('form1'),'email') ->printScript();?>" >
                    </td> 
                    <td align="left" width="300"><div id='divemail'></div></td>
                </tr>
                      <BR>
                <tr>    
                    <td align="right" width="220" class="Campos">Edad:</td>
                    <td width="200">     
                        <input tabindex="6" id="edad" type="text"  name="edad" size="28" maxlength="50" >
                    </td>
                    <td align="left" width="300"><div id='divedad'></div></td>
                </tr>    
                    <BR>
                <tr>
                     <td align='center' colspan='3'>
                          <INPUT tabindex="7" type="button" CLASS="boton" VALUE="Registrarse" onclick="xajax_FormProcess(xajax.getFormValues('form1'))">
                    </td>        
                </tr>
                    <br >
                </table>
                 </FORM>

thanks for all

Re: xajax's functions dont work on label <input>

Hi,

Perhaps you could post the whole html and the php. The form looks ok...

Ed

If you ever stop learning you may as well dig a hole, crawl in and pull the top over yourself.